Focus op Veiligheid. Cryptkeeper.

Cryptkeeper gebruikte door een bug altijd het wachtwoord ‘p’ voor versleutelde bestandssystemen. PHP 7.2 zal libsodium als standaardbibliotheek aannemen. En in systemd v228 was een lokale root exploit mogelijk. Deze en andere beveiligingsnieuwtjes lees je in Focus op veiligheid.

Cryptkeeper gebruikt altijd het wachtwoord ‘p’

Cryptkeeper is een system tray applet waarmee je eenvoudig met EncFS versleutelde mappen beheert. De interactie met EncFS bleek echter in de versie in Debian testing fout te lopen. Het programma probeert de paranoia-modus van EncFS in te schakelen door de gesimuleerde toetsindruk ‘p’ door te geven. In die modus gebruikt EncFS een voor gedefinieerde veilige configuratie. Maar in plaats van de toetsindruk ‘p’ door te geven, stelt Cryptkeeper ‘p’ als wachtwoord in voor de te versleutelen map…

De fout werd geïntroduceerd, omdat EncFS zijn implementatie veranderde en Cryptkeeper daaraan niet is aangepast. Cryptkeeper roept EncFS aan met de -S flag. Na de string “p\n” door te geven aan EncFS om de paranoiamodus in te schakelen, geeft Cryptkeeper het wachtwoord door. Vroeger werkte dat zo, maar dat stond niet zo in de documentatie. De EncFS-ontwikkelaar besloot om de implementatie aan de documentatie aan te passen. Daarna was EncFS niet meer compatibel met de veronderstellingen van Cryptkeeper. Het programma dacht dat het de opdracht voor paranoiamodus en daarna het wachtwoord aan EncFS doorgaf, terwijl EncFS onmiddellijk een wachtwoord verwachtte. Het stelde dus ‘p’ als wachtwoord in, sloot daarna onmiddellijk af en negeerde de rest van de invoer van Cryptkeeper.

De ontwikkelaar van Cryptkeeper lijkt zijn project verlaten te hebben, wat al een reden is om er niet mee te werken. Het is dan ook niet zo populair. Toch zit het programma in de repository’s van heel wat distributies. Debian heeft Cryptkeeper na de ontdekking van de fout uit de repository van de toekomstige Debian 9 gehaald. Niet alleen wordt het programma niet meer onderhouden, het controleert ook niet of de write- en close-aanroepen naar EncFS wel iets teruggeven, wat tot andere problemen kan leiden. Een ander programma, Sirikali, bleek op dezelfde manier van EncFS gebruik te maken. Deze beschamende fout maakt weer duidelijk dat je bij de keuze voor beveiligingssoftware ook moet kijken of de software wel goed onderhouden wordt.

https://tom.noflag.org.uk/cryptkeeper.html

PHP 7.2 zal moderne cryptografie hebben

De ontwikkelaars van de populaire scripttaal PHP hebben besloten om libsodium aan de basis van de taal toe te voegen in PHP 7.2, dat tegen het einde van dit jaar wordt verwacht. Libsodium is een moderne softwarebibliotheek voor encryptie, decryptie, wachtwoordhashing en meer cryptografische taken. Hiermee is PHP naar eigen zeggen de eerste programmeertaal die moderne cryptografie in zijn standaard bibliotheek toevoegt.

PHP 7.2 laat dus toe om eenvoudig en zonder optionele PHP-extensies te moeten installeren, gebruik te maken van moderne encryptie. In enkele regels code implementeer je geauthentiseerde encryptie en decryptie. Tot de primitieven die libsodium aanbiedt, behoren onder andere X25519 (Elliptic Curve Diffie-Hellman over Curve25519), Ed25519 (Edwards-curve Digital Signature Algorithm over Curve25519), Xsalsa20poly1305 (geauthentiseerde symmetrische encryptie), BLAKE2 (cryptografische hashfunctie), Argon2 (wachtwoord hashing en key derivation), SipHash-2-4 (een snelle hashfunctie voor hashtablellen) en ChaCha20-Poly1305 (geauthentiseerde encryptie met geassocieerde gegevens). Het voordeel van libsodium is dat je al deze details over de algoritmes niet hoeft te weten als je met de high-level API werkt.

https://secure.php.net/

Local root exploit in systemd v228 mogelijk

In systemd, het init-systeem waarnaar vele Linux-distributies de laatste jaren zijn overgestapt, werd een jaar geleden een fout opgelost waarbij een gebruiker de directory /run kon vullen en zo een denial-of-service aanval kon uitvoeren. Omdat de aanval alleen lokaal uit te buiten was, beschouwden de ontwikkelaars van systemd het niet als een belangrijke fout en vroegen ze geen CVE ID aan.

Sebastian Krahmer van het SUSE Security Team ontdekte echter dat een lokale gebruiker dankzij de fout willekeurige code als root kon uitvoeren. Wanneer je op systemd v228 timers instelde, creëerde het systeem bestanden met suid-bit die door iedereen beschrijfbaar zijn. Een aanvaller was dan in staat om zo’n bestand met een willekeurig programma te overschrijven en dit zo als rootgebruiker uit te voeren. De fout (die ondertussen wel een CVE ID heeft gekregen) is opgelost in systemd v229. Ze was slechts aanwezig in de Git-repository van november 2015 tot januari 2016. Als je nog een Linux-distributie draait die niet up-to-date is, bekijk dan of je kwetsbaar bent. De versie van je systemd-installatie vraag je op met de opdracht:

systemd –version

Kijk voor de zekerheid ook na of je geen timers met suid-bit hebt: 

ls -la /var/lib/systemd/timers/ 

Als je een bestand ziet met permissies -rwsrwsrwt, dan ben je kwetsbaar. Dat los je op door het bestand te verwijderen of (minder drastisch) de permissies aan te passen naar 0644. Dat laatste doe je met:

sudo chmod 0644 /var/lib/systemd/timers/*.timer

https://bugzilla.suse.com/show_bug.cgi?id=1020601 

Xen-project wil alleen nog advisory’s voor ernstige beveiligingsfouten

Het Xen-project zit in de maag met het werk om security advisory’s op te stellen. Het vergt namelijk heel wat werk om die op te stellen en uit te sturen. Het voorstel van de ontwikkelaars van de hypervisor is om lekken van alledaagse informatie van Xen of dom0 niet te beschouwen als een beveiligingsprobleem, tenzij ze natuurlijk gevoelige gebruikersgegevens of gegevens van een gast bevat. Ook als geen besturingssystemen kwetsbaar zijn voor een bug, wil het project niet langer een advisory uitsturen.

Een privilege escalation, denial of service en informatielek zal nog altijd als ernstige beveiligingsfout beschouwd worden. Maar niet in alle gevallen: als bijvoorbeeld de kernel van een gast een denial of service aanval op zichzelf kan uitvoeren door een bug, zal het project dat niet meer als een ernstige beveiligingsfout beschouwen die een advisory waard is. Ook beveiligingsfouten in functies die Xen als experimenteel of tech preview aanduidt, krijgen geen advisory’s meer.

https://blog.xenproject.org/2017/02/14/request-for-comment-scope-of-vulnerabilities-for-which-xsas-are-issued/

DEFT Zero 2017.1

Na meer dan 2,5 jaar heeft de Ubuntu-gebaseerde Linux-distributie DEFT (Digital Evidence & Forensic Toolkit) weer een nieuwe versie uitgebracht. De distributie bevat gespecialiseerde tools voor forensische analyse. De nieuwe versie, DEFT Zero 2017.1, is een lichtgewicht editie van de moederdistributie DEFT. Ze is gebaseerd op Lubuntu 14.04.02 LTS en de toekomstige versies zullen parallel met de volledige editie van DEFT worden ontwikkeld. Tot de nieuwe functies behoren de ondersteuning van UEFI, NVM Express-geheugen (van de MacBook 2015) en eMMC-geheugen. DEFT Zero heeft slechts 400 Mbyte RAM nodig.

http://www.deftlinux.net/ 

En verder

De nieuwssite van het openSUSE-project, news.opensuse.org, was gekraakt. De aanvallers publiceerden de Koerdische vlag en een defacement-boodschap op de website. Aangezien de website geïsoleerd was van de rest van de infrastructuur van het openSUSE-project, waren kritieke diensten van openSUSE niet in gevaar. De website wordt niet beheerd door openSUSE of SUSE, maar door SUSE’s moederbedrijf Micro Focus. Ze draaide op een verouderde WordPress-versie.

Tails 2.10 voegt OnionShare aan zijn collectie tools toe. Daarmee kunnen gebruikers bestanden over het Tor-netwerk delen. De Tor webbrowser toont nu de Tor-nodes waardoor je netwerkverkeer gerouteerd wordt. AdBlock Plus is vervangen door uBlock Origin. En de package manager apt maakt in de nieuwe Tails gebruik van Debian’s onion services. Het firewallbesturingssysteem OPNsense heeft zijn basis in versie 17.1 een upgrade gegeven naar FreeBSD 11.0. De installatie is nu via het netwerk mogelijk over een ssh-verbinding.

NEDLINUX FORUM

Het nederlandse linuxforum
Voor beginners en pro’s

 

 

 

 

E-mailadres



 

 

Nieuwste editie:

Linuxmag op Facebook

@linuxmagnl op Twitter

linuxmagNL Kaku is een open source desktop muziekspeler waarmee je op je Linux desktop computer bijvoorbeeld YouTube- en Vimeo… https://t.co/hTmhF1nf8e
linuxmagNL Ergens volgend in 2018 besluit de rijksoverheid of het gebruikelijk wordt om de broncode vrij te geven van software… https://t.co/gVamPo31OF
linuxmagNL Umbrello is een open source UML modeller op basis van de KDE-technologie en biedt alle functionaliteiten die je van… https://t.co/yR1tewHPxA