Linux Tips: welke programma's moet ik herstarten?

Met Linux hoef je niet om de haverklap je computer te herstarten bij een update, in tegenstelling  tot de normale gang van zaken in de Windows-wereld.Toch zal het regelmatig voorkomen dat je  na een upgrade bepaalde programma’s herstart, omdat ze anders de oude versies van library's blijven gebruiken. Maar hoe weet je nou welke programma's je moet herstarten?

Zonder antwoord op die vraag ben je eigenlijk verplicht om toch je hele computer maar te herstarten. Zeker als het om een webserver gaat waar de hele wereld toegang tot heeft. Dan wil je niet dat je Apache-webserver nog een oude versie van OpenSSL gebruikt, waar juist een beveiligingslek in is gedicht...

 

Onder Debian en Ubuntu bestaat gelukkig een handige tool die je een antwoord op die vraag geeft, namelijk het programma checkrestart uit het pakket debian-goodies. Voer je dit programma als root uit (sudo checkrestart), dan toont het programma het aantal programma's dat momenteel verouderde bestanden gebruikt en de procesnummers en procesnamen waar het om gaat. Als de programma's een init-script hebben, worden die ook getoond, zodat je weet met welke opdracht je de programma's herstart. Processen zonder init-script zijn geen services, maar programma's die je zelf hebt opgestart. Als je die afsluit en terug opstart, weet je zeker dat de nieuwste bestanden gebruikt worden. Met de optie -v krijg je ook de out-of-date bestanden te zien waar het om gaat.

 

Voor Fedora bestaat er een gelijkwaardige tool: needs-restarting uit het pakket yum-utils. Met sudo needs-restarting krijg je een lijst van programma's die je moet herstarten. Je zou hier het best een gewoonte van kunnen maken om deze tool (of checkrestart als je Debian of Ubuntu gebruikt) altijd na een upgrade uit te voeren en de gevonden programma's te herstarten. Zo hoef je niet je hele computer te herstarten om er zeker van te zijn dat je de nieuwste library's gebruikt.

 

Overigens moet je na een upgrade van de kernel altijd rebooten om de nieuwe kernelversie te gebruiken, tenzij je een tool voor live kernel patching gebruikt, zoals Ksplice of kGraft, maar dat zijn nog vrij experimentele technologieën. Onder Debian en Ubuntu kun je met /usr/lib/update-notifier/update-motd-reboot-required opvragen of je je computer wegens een kernelupdate moet herstarten. Daarvoor moet je eerst het pakket update-notifier-common installeren.

NEDLINUX FORUM

Het nederlandse linuxforum
Voor beginners en pro’s

 

 

 

 

E-mailadres



 

 

Nieuwste editie:

Linuxmag op Facebook

@linuxmagnl op Twitter

linuxmagNL Linux Nieuws: @SUSE bestaat 25 jaar en trakteert! Maak kans op entreeticket voor #SUSECON in Praag, zie link!… https://t.co/ENJKDvyZQ8
linuxmagNL De nieuwe editie van Linux Magazine is weer uit! Thema: bescherm jezelf tegen hackers met Linux. Veel leesplezier a… https://t.co/Zcy3Zdjb90
linuxmagNL Ook de Red Hat Forum BeNeLux 2017 mag je dit jaar niet missen. 10 oktober 2017, zet het in je agenda! https://t.co/niY9UdK3Ov